Unwanted start of KB rhythm settings and sounds when playing back midi


I successfully record  a midi passage starting at bar 1 using my KN5000 and Cubase Elements 9.5 as my DAW. When I try to play it back (from bar  1) it plays OK but at the the same time it starts the Keyboard playing the rhythms that are set on it (which I don’t want). If I move the recording to start at bar 2 and set this as the starting point then it plays back the midi correctly with no other sounds from the keyboard. How can I get it to start from bar 1 without added sounds?

I don’t know whether   the trigger for the keyboard is in the KN settings or is in Cubase. I am trying to contact cubase support but have no reply from them yet. I will keep trying on this.

I have reset the keyboard using Bob’s pages at the site


and choosing ” MIDI OUT WITH PC  and that was very helpful in re-setting the keyboard.



Viewing 3 replies - 1 through 3 (of 3 total)
  • #9411

    Hi Roystond,

    You should be able to disable this in Cubase but I don’t know the program well enough to understand how.

    Refer to Page 168 in the KN5000 Manual – Realtime Messages. Turning off the keyboard’s Realtime Commands should achieve what you want.

    The manual is not 100% clear as to whether you need to do that every time you turn on the keyboard.

    Hope that helps,


    If architecture is frozen music then music must be liquid architecture. Quincy Jones

  • #9507

    Hi All and Roystond

    Please post replies in the forum not by email because it saves me from copying and pasting them into the forum, thanks 🙂

    replied as follows:

    Hello Mike

    Thank you for your help. I have now sorted this.

    As you say the answer is in Realtime messages/Realtime commands. Putting this as OFF means no start signal is received from Cubase. I can therefore proceed as follows.

    With Realtime Commands OFF I can record midi by setting the KB to say 80 bpm AND the project tempo to 80 bpm. Make KB ready by having the start/stop blinking and putting synchro start on. I can then play a chord records (with memory on) – OK

    One drawback is that this way the recording is at the same tempo as is set but it does not necessarily start at the beginning of a bar. I can overcome this by quantizing but it has to be very accurate.  (Is there a better way?)

    Alternatively on the KB I can set Realtime command to ON with same settings as above and it will start the recording (backing) at either the start of a piece or the left cursor (as set). This is automatically in sync and if it wants moving I can do it by setting Quantize to 1 and doing it. I then turn real time command OFF again.

    All this applies to midi track and instrument tracks which are mainly the backing. Some midi tracks I will just play in.

    Best, Roystond

    If architecture is frozen music then music must be liquid architecture. Quincy Jones

  • #9508

    I was thinking about this. There must be a better way. Unfortunately, I can’t experiment right now.

    What if you created a Composer rhythm that is ‘clear’, i.e. it has no rhythm instruments? Then, you could have realtime commands on for full synchronisation, but you wouldn’t hear any rhythm.

    You might also make a separate Composer (B) with a click track if you need one, and swap between the two when you like. Save them on floppy or, even better, as a Custom Rhythm and off you go. You could have several of them for different time-signatures.

    If architecture is frozen music then music must be liquid architecture. Quincy Jones

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.